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Getting started with Sprocket
Sprocket is a free video editor for Windows, macOS, and Linux. You arrange video and audio clips
on a timeline, trim and rearrange them, adjust how they look and sound, and then export a finished
movie file you can share.

Your edits are non-destructive — trimming, splitting, and adding effects never change your
original video and audio files. You’re always free to change your mind.

This guide gets a real project on screen, takes you on a quick tour, and then walks through the
most common tasks in the order you’ll usually do them.

System requirements
Sprocket runs on:

Windows — Windows 10 (64-bit, version 1809 or later) or Windows 11, on x64 or ARM64.

Linux — x64 (AppImage) or arm64 (portable zip).

macOS — Apple Silicon or Intel.

Every download is self-contained: there is nothing else to install — no .NET runtime and no FFmpeg
setup.

What’s in this guide
System requirements

Open something to work with

A quick tour of the main screen

The most common tasks, in order
1. Play and preview your video

2. Zoom the timeline in and out

3. Select a clip

4. Trim a clip

5. Split a clip with the Blade

6. Move, delete, and close gaps

7. Change how a clip looks



8. Adjust the audio

9. Add a track

10. Undo and redo

11. Save your project

12. Export your finished video

Keyboard shortcuts worth knowing

Where to go next

Open something to work with
When Sprocket starts, it opens an empty project. The quickest way to see the editor in action is to
load the built-in sample:

1. Open the File menu in the top-left.

2. Choose Open Sample Project.

A short sample video and its audio appear on the timeline, ready to edit. The project name
(sample) and a • all changes saved indicator show at the top of the window.

When you’re working on your own footage, you have a few other ways to get started from this
same File menu:



New Project (Ctrl+N) — start from scratch with one video and one audio track.

Import Media… (Ctrl+I) — bring your own video and audio files into the project. You can

also drag files straight from your file browser onto the Project panel.

Open Project… (Ctrl+O) — reopen a project you saved earlier.

Tip: Importing media only adds it to your project’s library — it doesn’t put it on the timeline yet.
You’ll drag it onto a track when you’re ready to use it.

A quick tour of the main screen
Here’s the lay of the land. Every panel is resizable — drag the dividers between them to give
yourself more room where you need it.

1. Menu bar — all of Sprocket’s commands, grouped into File, Edit, Clip, Sequence, Effects,
View, Window, and Help. The center shows your project’s name and whether your changes
are saved; the window buttons are on the right.

2. Toolbar — your editing tools on the left (Select, Blade, Ripple, Roll, Slip, Slide, Hand, and
Zoom), the Snapping and Linked toggles next to them, and the Export button on the right.
The label in between (for example, Sequence 1 · 1080p · 29.99) tells you the video size and
frame rate you’re editing at.

3. Project panel — the library of media in your project, with Media, Effects, Transitions, and
Audio tabs and a search box at the top.



4. Program monitor — a live preview of your finished video at the current point in time. Below
it are the playback controls and a timecode readout. The Guides button overlays framing
guides, the Fit menu sets how large the preview is drawn, and the Scopes menu next to it
turns on waveform, vectorscope, and other monitoring overlays for color work.

5. Inspector — the properties of whichever clip you’ve selected. It stays empty (“No clip
selected”) until you click a clip on the timeline.

6. Timeline — your tracks stacked over time, with video tracks (V1) on top and audio tracks
(A1) below. A ruler runs across the top and a vertical playhead marks the current point. The
zoom buttons, Markers, and + Track controls sit at its top-right.

The thin strip along the very bottom is the status bar. It shows whether Sprocket is ready or
playing on the left, an AI control (MCP) indicator next to it when that’s turned on, a running
message in the middle (like “Opened sample project”), and live playback stats — frame rate, video
size, and duration — on the right.

The most common tasks, in order
1. Play and preview your video
Use the controls under the Program monitor to watch your edit.

Click the play button (or press the Space bar) to start and stop playback. It turns into a pause
button while playing.



The buttons on either side let you jump to the start, step back one frame, step forward
one frame, and jump to the end.

Drag the slider (the scrubber) to jump to any moment. The timecode on the left shows where
the playhead is; the one on the right is the total length.

To scrub through the timeline itself, drag along the ruler at the top of the Timeline — the playhead
follows your cursor and the preview updates as you go.

2. Zoom the timeline in and out
Longer projects need more room. Use the – and + buttons at the top-right of the Timeline to
zoom out and in (or press Ctrl+- and Ctrl+=). To fit the whole project across the width of the
window, press Shift+Z.

3. Select a clip
Most editing starts by telling Sprocket which clip you want to work on. With the Select tool active
(the default), click a clip on the timeline. A colored border marks it as selected, and the Inspector
on the right fills in with that clip’s details.

The Inspector’s top section shows the clip’s Source file, where it starts, its duration, and how
much of the original media it uses (Trim). Everything below that is the clip’s effects, which you’ll
adjust in a moment.



4. Trim a clip
Trimming shortens or lengthens a clip by moving its start or end point.

1. Make sure the Select tool is chosen.

2. Move your cursor to the left or right edge of a clip until the cursor changes to a trim handle.

3. Drag the edge inward to hide part of the clip, or outward to reveal more of the original
footage.

Because trimming is non-destructive, dragging an edge back out always brings your footage back
— nothing is lost.

Tip: Leave Snapping turned on (in the toolbar) so clip edges click neatly into place against other
clips and the playhead as you drag.

5. Split a clip with the Blade
The Blade tool cuts one clip into two so you can remove or rearrange a section.

1. Move the playhead to where you want the cut.

2. Click the Blade tool in the toolbar.

3. Click the clip at the point you want to split it.

4. Switch back to the Select tool to move or delete either piece.



Blading only cuts the clip you click on. In the sample project, the music on A1 is its own separate
clip, so it’s untouched by a cut on V1. When a clip’s video and audio do come from the same
source (a video you recorded with its own sound), the Linked toggle keeps that pair moving and
cutting together. Turn Linked off if you ever need to edit a clip’s picture and sound separately.

6. Move, delete, and close gaps
Move a clip: with the Select tool, drag a clip left or right along its track, or up and down to
another track.

Delete a clip: select it and press Delete. This leaves a gap where the clip was.

Delete and close the gap: press Shift+Delete (Ripple Delete) to remove the clip and slide
everything after it back to fill the space.

You’ll find all of these in the Edit menu too, alongside the usual Cut, Copy, and Paste.

7. Change how a clip looks
Effects adjust a clip’s picture and sound — brightness, color, size, position, and fades. Select the
clip, open the Effects menu, and choose an effect; it appears as a new section in the Inspector,
where you drag a slider or type a value to adjust it. Transform, Color, Brightness, and Fade cover
the everyday adjustments.

See Effects & the effect stack for the full set — adding, removing, and stacking effects — and
Color grading for finer control over color.

8. Adjust the audio
Each audio track has M (mute) and S (solo) buttons in its header at the left of the timeline. To fade
a clip’s audio in or out, select it and add the Fade effect from the Effects menu, the same way you
added a picture effect. (Video tracks have their own toggle — the eye icon — to hide or show a
track’s picture.)

See Audio levels & the mixer for more.

9. Add a track
Need another layer of video or a second audio track? Click + Track at the top-right of the Timeline
and choose Add Video Track or Add Audio Track.

http://localhost:4321/docs/effects-color/effects
http://localhost:4321/docs/effects-color/color-grading
http://localhost:4321/docs/audio/audio-mixing


Higher video tracks appear in front — a clip on V2 shows over a clip on V1 at the same moment.

10. Undo and redo
Made a mistake? Press Ctrl+Z to undo, or Ctrl+Shift+Z to redo. Sprocket even names each step,
so the Edit menu shows exactly what you’re about to undo (for example, “Undo Split clip”).

11. Save your project



Save your work with File ▸ Save Project (Ctrl+S). The first time, Sprocket asks where to put the
project file. After that, Ctrl+S saves over it, and the indicator at the top of the window switches

from • unsaved changes back to • all changes saved.

To keep a separate copy, use File ▸ Save Project As… (Ctrl+Shift+S).

A saved project remembers your timeline and edits, not the video itself — keep your original
media files where they are. If you do move them, use File ▸ Relink Media… to point Sprocket at
their new location.

12. Export your finished video
Click the Export button in the top-right (or press Ctrl+E), choose your settings in the Export
Settings window, then click Export… and pick where to save the file. The defaults produce a widely
compatible MP4 file (H.264 video, AAC audio) at your project’s size and frame rate.

See Exporting your video for the format, quality, burn-in, and preset options.

Keyboard shortcuts worth knowing
Shortcut What it does

Space Play / pause

Ctrl+Z / Ctrl+Shift+Z Undo / redo

Ctrl+X · Ctrl+C · Ctrl+V Cut · copy · paste

Delete / Shift+Delete Delete / delete and close the gap

Ctrl+- / Ctrl+= Zoom the timeline out / in

Shift+Z Zoom the timeline to fit

Ctrl+I Import media

Ctrl+S / Ctrl+Shift+S Save / save as

Ctrl+E Export

M Add a marker at the playhead

http://localhost:4321/docs/export/exporting


On macOS, use ⌘ where these show Ctrl. For the complete list — grouped by task, with every
platform difference — see the keyboard shortcut reference.

Where to go next
You now know enough to build a real edit from start to finish: bring in media, arrange and trim it
on the timeline, adjust how it looks and sounds, and export the result.

From here:

Editing on the timeline goes deeper on the toolbar — the Ripple, Roll, Slip, and Slide tools
that each trim and shuffle clips in a different way, plus snapping, linked audio and video, and
closing gaps.

Try keyframing an effect for movement (the small diamond next to each Inspector setting),
and use the Markers button to leave notes for yourself along the timeline.

http://localhost:4321/docs/get-started/keyboard-shortcuts
http://localhost:4321/docs/edit/editing-on-the-timeline


Keyboard shortcuts
Keyboard shortcuts are the fastest way to work in Sprocket. This page lists every shortcut, grouped
by what you’re trying to do.

Tip: The shortcuts below are written for Windows and Linux, where the main modifier key is
Ctrl. On macOS, use ⌘ (Command) wherever you see Ctrl — for example, Ctrl+S becomes
⌘S. A few shortcuts differ between platforms; those differences are called out as you go and

summarized in macOS differences at the end.

What’s in this guide
Playback and transport

Files and projects

Editing

Selection and clipboard

Timeline zoom

In and out points

Markers

Keyframes

Multicam

Full screen

macOS differences

Playback and transport
Shortcut What it does

Space Play / pause the active monitor

Ctrl+Shift+Space Play only the marked range (from the In point to the Out point)

Tip: Playback shortcuts act on whichever monitor is active — the Program monitor (your
timeline) or the Source monitor (a clip you’re previewing).



Files and projects
Shortcut What it does

Ctrl+N New project

Ctrl+O Open a project

Ctrl+S Save

Ctrl+Shift+S Save As

Ctrl+I Import media

Ctrl+E Export

Ctrl+Shift+E Open the export queue

Ctrl+, Open Preferences

On macOS you can also press ⌘Q to quit Sprocket. On Windows and Linux, quit with the usual
Alt+F4 or by closing the window.

Editing
These shortcuts act on the clips selected on the timeline.

Shortcut What it does

Ctrl+Z Undo

Ctrl+Shift+Z Redo

Ctrl+Y Redo (Windows and Linux only)

Ctrl+K Split the clip at the playhead

Ctrl+L Link or unlink the selection (links an eligible multi-selection,
otherwise unlinks the selected clip’s group)

Shift+E Enable or disable the selected clip



Shortcut What it does

Delete or Backspace Delete the selection, leaving a gap

Shift+Delete or

Shift+Backspace

Ripple delete — delete the selection and close the gap

Alt+← Nudge the selected clip one frame left

Alt+→ Nudge the selected clip one frame right

Selection and clipboard
Shortcut What it does

Ctrl+A Select all clips

Ctrl+X Cut

Ctrl+C Copy

Ctrl+V Paste at the playhead

Tip: When you’re typing in a text field — the media search box or a numeric box in the Inspector
— these keys keep their normal behavior (for example, Ctrl+A selects the text). The timeline
shortcuts take over again as soon as you click away from the field.

Timeline zoom
Shortcut What it does

Ctrl+= Zoom in

Ctrl+- Zoom out

Shift+Z Zoom to fit the whole timeline

Both the main number-row keys (= / -) and the numeric keypad + / - keys work for zooming.



In and out points
Mark a range on the timeline to export just that section, or to play only that part.

Shortcut What it does

I Set the In point at the playhead

O Set the Out point at the playhead

Alt+I Clear the In point

Alt+O Clear the Out point

Ctrl+Shift+Space Play the marked range (In to Out)

Markers
Markers are notes you leave along the timeline.

Shortcut What it does

M Add a marker at the playhead

Shift+M Jump to the next marker

Ctrl+Shift+M Jump to the previous marker

Keyframes
When a clip with keyframed effect settings is selected, jump between its keyframes.

Shortcut What it does

[ Jump to the previous keyframe

] Jump to the next keyframe



Multicam
When a multicam clip is selected, the number keys cut to a camera angle at the playhead.

Shortcut What it does

1–9 Switch to that camera angle

The number keys only switch angles while a multicam clip is selected; otherwise they do nothing.

Full screen
Shortcut What it does

Ctrl+F Show the current monitor full screen (a distraction-free preview)

F11 Make the whole Sprocket window full screen

Esc Exit full-screen preview, then exit window full screen

Press Esc once to leave the full-screen preview; press it again to leave window full screen. Playback
and transport shortcuts keep working while a preview is full screen.

macOS differences
Sprocket follows the platform’s conventions, so a few shortcuts differ on macOS:

On Windows / Linux On macOS

Ctrl + a key ⌘ (Command) + the same key

Ctrl+Y (redo) Use ⌘⇧Z — there is no Ctrl+Y

Alt+F4 (quit) ⌘Q

F11 (window full screen) F11 or ⌃⌘F (some Mac keyboards treat F11 as a media key)

On macOS, Ctrl is not an alias for ⌘ — the two are separate modifiers, matching how other
professional editors behave.



Related
Getting started with Sprocket — a tour of the main screen and the most common editing
tasks.

Editing on the timeline — the trim tools, snapping, linked clips, and nudging in depth.

http://localhost:4321/docs/get-started/getting-started
http://localhost:4321/docs/edit/editing-on-the-timeline


Working with log & camera footage
Some cameras record “log” footage — flat, low-contrast, and desaturated by design, to preserve as
much dynamic range as possible for grading later. Before you grade it (or export it), log footage
needs a conversion to a standard picture. Sprocket handles that with two effects you add to the clip
like any other.

Once the footage is converted, you grade it with the usual tools — see Color grading.

What’s in this guide
Log footage: Input Color Transform and ACES Filmic

Log footage: Input Color Transform and ACES
Filmic
Some cameras record “log” footage — flat, low-contrast, and desaturated by design, to preserve as
much dynamic range as possible for grading later. Log footage needs a conversion before it looks
right; these two effects handle that.

Input Color Transform converts a specific camera manufacturer’s log format to standard Rec.709
video. Pick your camera’s profile from the Source Profile list:

http://localhost:4321/docs/effects-color/color-grading


Add this effect first, before any other grading effect on the clip — grading tools like Color Wheels
and Curves are designed to work on a normal image, not flat log footage.

ACES Filmic applies a filmic tone-mapping curve, which rolls off highlights more gently than a
straight conversion — useful for footage with a very wide dynamic range (bright skies, strong
practical lights in frame) that would otherwise clip harshly. It has a single Exposure control to set
the input brightness before the curve is applied:

If your footage isn’t log (most phone and camera footage recorded in a standard picture profile
isn’t), you don’t need either of these effects — go straight to White Balance, Color Wheels,
Curves, or HSL Qualifier.

Related
Color grading — grade the footage once it’s converted, and judge the result with scopes.

http://localhost:4321/docs/effects-color/color-grading


Editing on the timeline
Once you have clips on the timeline, most of your work is trimming and rearranging them:
tightening a shot, changing where one clip cuts to the next, closing a gap. Sprocket gives you a row
of editing tools for exactly this. This guide explains what each one does and when to reach for it.

If you haven’t yet, start with the Getting started guide — it covers opening a project, the basics of
selecting and splitting clips, and the layout of the screen.

Before you start
You’ll need a project with a few clips on the timeline. The quickest way to follow along is File ▸
Open Sample Project, then split the clip into a few pieces with the Blade tool (see Split a clip with
the Blade) so you have several clips to work with.

What’s in this guide
The editing tools

Select — move and trim

Selecting several clips at once

The four trim tools: Ripple, Roll, Slip, Slide

Snapping

Keeping audio and video together

Moving clips between tracks

Renaming and resizing tracks

Nudging with the keyboard

Deleting clips and closing gaps

Cut, copy, and paste

Splitting a clip at the playhead

Duplicating a clip

Turning a clip off without deleting it

The right-click menu

Fading a clip in or out

Changing a clip’s speed

http://localhost:4321/docs/get-started/getting-started
http://localhost:4321/docs/get-started/getting-started#5-split-a-clip-with-the-blade
http://localhost:4321/docs/get-started/getting-started#5-split-a-clip-with-the-blade


Freezing a frame (frame hold)

Duplicate or remove a single frame (stop motion)

Getting around: Hand and Zoom

The editing tools
The tools live in a row at the top-left of the window. One tool is active at a time, and the active
tool decides what happens when you click or drag a clip on the timeline. Click a tool to switch to it.

Select, Blade, Ripple, Roll, Slip, and Slide change or rearrange your clips.

Hand and Zoom just change your view of the timeline — they don’t touch your clips.

Snapping and Linked (to the right of the tools) are toggles that stay on or off across every
tool.

Select is the tool you’ll use most; switch to a specialized tool for a specific edit, then switch back.

The cursor tells you what will happen before you click. Each tool has its own pointer, and it
changes shape as you hover over different parts of a clip — over a clip’s edge with Select it
becomes a trim bracket, the Blade shows a razor, the trim tools show their own brackets and
arrows. The Blade also draws a faint vertical line where your next click will cut, so you can line the
cut up exactly before committing to it.

Select — move and trim
The Select tool (the default) does the two most common things:

Move a clip — drag it left or right along its track, or up and down to another track.

Trim a clip — hover over a clip’s left or right edge until the cursor becomes a trim handle,
then drag the edge inward to shorten the clip or outward to reveal more of the original
footage.

Trimming with Select leaves everything else where it is — shortening a clip opens a gap next to it. If
you’d rather close the gap automatically, use the Ripple tool instead.



Selecting several clips at once
Most edits act on one clip, but you can select several and move, delete, or copy them together.
With the Select tool:

Ctrl-click a clip to add it to (or remove it from) the selection.

Shift-click a clip to extend the selection.

Drag across empty track space to draw a marquee — a selection box that grabs every clip it
touches. Hold Ctrl or Shift while you drag to add to what’s already selected.

Ctrl+A (Edit ▸ Select All) selects every clip on the timeline.

The selected clips are outlined in the accent colour. One of them — the last one you clicked — is
the primary clip, drawn with a brighter outline than the rest:

The primary clip is the one the Inspector shows and the one that dialogs like Speed / Duration act
on. Everything else — Delete, Ripple Delete, Cut, Copy, Duplicate, nudging, enabling and
disabling — acts on the whole selection as a single undo step. Drag any selected clip and the entire
set moves together, keeping their spacing.

The four trim tools: Ripple, Roll, Slip, Slide
These four tools all adjust clips that sit next to each other, each in a different way. They’re the tools
that separate quick edits from tidy ones, so they’re worth learning. Here’s what each does (the app
shows the same description as a tooltip when you hover over the tool):

Ripple
Trim a clip’s edge, and everything after it shifts to keep the timeline gap-free. Because the
downstream clips move, the total length of your video changes.

Reach for Ripple when you want to tighten (or extend) a clip and automatically close (or open) the
gap, without leaving a hole to clean up later.



Roll
Drag the cut point between two adjacent clips. The first clip’s end and the second clip’s start
move together, so their combined length — and everything downstream — stays exactly where it
is.

Reach for Roll when a cut happens a beat too early or too late and you want to change where one
shot becomes the next, without shifting the rest of your edit.

Slip
Change which part of a clip’s footage plays, without moving the clip. The clip keeps its exact
position and length on the timeline; only the in and out points into the original footage shift.

Reach for Slip when a clip sits in the right spot and is the right length, but you want to show a
different moment from within it. (There’s nothing to animate here — the clip stays exactly where it
is; only the footage playing inside it changes.)

Slide
Move a clip along the timeline while its neighbours absorb the change. The clip before it
lengthens and the clip after it shortens (or the reverse), so the overall length and everything else
stay put.

Reach for Slide when you want to reposition a clip that’s sandwiched between two others without
leaving a gap.



At a glance

Tool You grab… What moves What stays the same

Ripple a clip’s edge that clip’s length + everything
downstream shifts

no gaps are left

Roll the cut between
two clips

where one clip ends and the next
begins

total length, everything
downstream

Slip a clip’s body which footage plays inside the
clip

the clip’s position and
length

Slide a clip’s body the clip’s position; neighbours
resize to fit

total length, everything
else

Tip: Ripple, Roll, and Slide all work on a clip that has a neighbour to act on. Slip needs a clip with
unused footage before or after the part you’re using (a clip you’ve already trimmed).

Snapping
Snapping makes clip edges and the playhead click into place against nearby edits, markers, and
the playhead while you drag — so cuts line up cleanly instead of leaving a one-frame sliver. It’s on
by default; toggle it from the toolbar if you need to place something freely.

Keeping audio and video together
Linked keeps a video clip and its companion audio joined, so they move, trim, and cut together as
one — for a clip that was imported with its own synced sound. It has no effect on unrelated clips: in
the sample project, the music on A1 is a separate clip from the video on V1, so cutting one never
affects the other.



Turn Linked off when you deliberately want to edit the picture and sound separately — for
example, to let the audio from one shot carry over while the video cuts to the next (a “J” or “L” cut).

You can also create or break a link yourself. Select a video clip and an audio clip (see Selecting
several clips at once) and choose Clip ▸ Link to join them into a linked pair; select a linked clip and
choose Clip ▸ Unlink to separate it. Ctrl+L does whichever one fits your selection — it links an
eligible video-plus-audio selection, or unlinks a clip that’s already part of a group.

Moving clips between tracks
With the Select tool, drag a clip up or down onto another track of the same kind (video onto a
video track, audio onto an audio track). Higher video tracks appear in front, so moving a clip up to
V2 places it over whatever is on V1 at the same time. Add more tracks with + Track at the top-right
of the timeline.

Renaming and resizing tracks
Tracks start with plain names like V1 and A1, but you can rename them — “Music,” “Dialogue,”
“Titles” — to keep a busy project straight. Double-click a track’s name in the header column on
the left, type the new name, and press Enter (or click away) to save it. Escape cancels.

If long names don’t fit, drag the right edge of the header column to make it wider or narrower.
The pointer becomes a resize arrow over the edge. (This is just for the current session — the
column returns to its default width next time you open the project.)

Nudging with the keyboard
For small, precise moves, select a clip and nudge it one frame at a time:

Alt+← — nudge the clip left

Alt+→ — nudge the clip right

This is handy for lining up a cut to a beat in the music or a specific frame of action.

Deleting clips and closing gaps



There are two ways to remove a clip, and the difference is what happens to the space it leaves
behind.

Say you have three clips in a row:

Delete (Delete) removes the selected clip and leaves a gap where it was. The clips after it stay put:

Ripple Delete (Shift+Delete) removes the clip and slides everything after it back to close the gap,
so your video gets shorter with no empty space:



Both are also in the Edit menu.

Cut, copy, and paste
Clips go on the clipboard like text does, so you can lift a clip from one spot and drop it in another:

Cut (Ctrl+X) removes the selected clip(s) and puts them on the clipboard.

Copy (Ctrl+C) copies without removing.

Paste (Ctrl+V) drops them back onto the timeline.

The key thing to know is where a paste lands: at the playhead. Position the playhead where you
want the clip to start, then paste. If you copied several clips at once, the earliest one lands at the
playhead and the rest keep their spacing relative to it — so you can copy a whole arranged section
and drop it elsewhere intact, as one undo step. Pasted clips are independent copies, so editing a
copy never changes the original.

Splitting a clip at the playhead
Besides the Blade tool, you can split the selected clip right where the playhead sits: choose Clip ▸
Split at Playhead (Ctrl+K). This is handy when the playhead is already parked on the exact frame
— you don’t have to aim the Blade. If the clip has linked audio, its companion splits at the same
point.

Duplicating a clip
Clip ▸ Duplicate makes a copy of the selected clip and places it right after the original on the
same track. It’s a quick way to repeat a shot without going through copy-and-paste. Linked video
and audio duplicate together as a fresh linked pair.



Turning a clip off without deleting it
Sometimes you want to silence or hide a clip without removing it — to try your edit without a shot,
or to mute one clip while keeping the rest of the track. Select it and choose Clip ▸ Enable
(Shift+E) to toggle it off.

A disabled clip stays in place but plays nothing — no picture, no sound — and is drawn dimmed on
the timeline so you can see it’s off. Toggle Enable again to switch it back on. (The menu item shows
a checkmark when the clip is enabled.)

The right-click menu
Everything above — and the speed, frame-hold, and other clip commands later in this guide — is
also a right-click away. Right-click a clip to open a menu of the actions that apply to it:

The menu is shaped to the clip you clicked. A video clip adds the Frame Hold commands,
Interpret Footage, and Multicam; an audio clip adds Normalize Audio. It’s often faster than
reaching for the menu bar, because it only lists what’s relevant to that clip.



Fading a clip in or out
You can fade a clip right on the timeline, without adding an effect. Select a clip (with the Select
tool) and you’ll see a small triangle handle in each of its top corners. Drag the left handle inward
to fade the clip in, and the right handle inward to fade it out — the further you drag, the longer the
fade:

There’s also a horizontal level line running across the top of the clip. Drag it up or down to set the
clip’s overall opacity (for video) or volume (for audio). Ctrl-click the line to add a point, so you can
shape the level up and down across the clip rather than setting one flat level.

Tip: These on-clip fades are the quick, visual way to fade. For a fade with an exact duration you
can type in, or an audio-only fade, use the Fade effect instead — see Adjust the audio.

Changing a clip’s speed
Select a clip and choose Clip ▸ Speed / Duration… to play it back faster or slower. Type a
percentage or click one of the presets, then Apply:

Below 100% slows the clip down — 50% plays at half speed.

Above 100% speeds it up — 200% plays at double speed.

Changing the speed changes how long the clip takes on the timeline — the footage itself
doesn’t change, only how fast it plays. Speeding a clip up shortens it; slowing it down lengthens it.
The Inspector’s Duration row updates to match:

http://localhost:4321/docs/audio/audio-mixing#adjust-the-audio


Tip: You can also type a new percentage straight into the Speed row in the Inspector — no need
to open the dialog for a quick change.

If the clip has linked audio, its companion clip speeds up or slows down with it, so picture and
sound stay in sync.

Freezing a frame (frame hold)
Sometimes you want the video to pause on one frame — a freeze-frame ending, a beat before a
title comes up, holding on a reaction shot — without leaving a gap or shortening anything else on
the timeline. Sprocket calls this a frame hold, and it lives on the Clip menu, right below Speed /
Duration:



Frame Hold Options… freezes the whole selected clip on one frame — the frame under the
playhead by default, or its in point, or an exact source time you type in:

The clip’s length on the timeline doesn’t change — only what’s playing during it. Once applied, a
HOLD badge appears on the clip and the Inspector’s Hold row shows the frozen frame and how
long the hold lasts:



To release a hold, reopen Frame Hold Options…, clear the Hold on frame checkbox, and click OK.

Two related commands sit just below it on the same menu:

Add Frame Hold splits the clip at the playhead and freezes only the second half on that
frame — for holding on the last frame of a shot without affecting the part before the split.

Insert Frame Hold Segment inserts a new, separate 2-second freeze of the playhead frame
into the clip and pushes everything after it later — for adding a deliberate pause in the
middle of a shot.

Tip: Frame hold only applies to video clips — it’s not available for audio.

Duplicate or remove a single frame (stop motion)
The last two commands in the frame-hold group work one frame at a time. They’re made for stop-
motion-style work — repeating each frame so the footage plays “on twos” — and for micro-timing:
adding or trimming a single frame so a cut lands exactly on a beat.

Select the clip, put the playhead on the frame you want, then:

Clip ▸ Duplicate Frame inserts a one-frame freeze of that frame immediately after it, and
everything after it on the timeline moves one frame later. Repeat it to hold the frame longer
— duplicating twice plays the frame three times.



Clip ▸ Remove Frame deletes that frame’s slice of the clip and closes the gap, so everything
after it moves one frame earlier.

These are tiny edits — at a normal zoom you won’t see anything change. Zoom far in (Ctrl+=) and
a duplicated frame shows up as its own miniature segment wedged into the clip:

The inserted segment is a regular frame hold — select it and the Inspector’s Hold row shows which
frame it repeats.

Each command is a single undo step (Ctrl+Z puts the frame back), and neither is available on a clip

that’s already frozen with a frame hold.

Tip: “One frame” means one frame of the clip’s original footage. On a slowed-down clip that
frame plays for longer than one timeline frame, so the piece you add or remove is
correspondingly longer too.

Getting around: Hand and Zoom
These two tools change your view without changing your edit:

Hand — drag to pan the timeline left and right when your project is longer than the window.

Zoom — click the timeline to zoom in for frame-accurate work; Alt-click to zoom back out.

You can also zoom with the – / + buttons at the top-right of the timeline (or Ctrl+- / Ctrl+=), and
press Shift+Z to fit the whole project in view.

Related
Getting started — the basics of opening a project, selecting, splitting, effects, and exporting.

Split a clip with the Blade

Marks and markers — set an in/out range and drop markers.

Titles, generators, and adjustment layers — add titles and other generated clips.

Multicam and sequences — cut between angles, work with multiple timelines, and nest clips.

http://localhost:4321/docs/get-started/getting-started
http://localhost:4321/docs/get-started/getting-started#5-split-a-clip-with-the-blade
http://localhost:4321/docs/edit/marks-and-markers
http://localhost:4321/docs/edit/titles-and-generators
http://localhost:4321/docs/edit/multicam-and-sequences


Export your finished video

http://localhost:4321/docs/export/exporting#export-your-finished-video


Marks and markers
As your edit grows, you’ll want ways to point at specific moments — “start the export here,” “this is
where the music drops,” “come back and fix this cut.” Sprocket gives you two tools for that: in and
out marks define a range of the timeline to work on, and markers drop labelled pins at single
moments you want to find again.

Both live on the timeline ruler and work no matter which editing tool is active.

What’s in this guide
In and out marks

Play just the marked range

Markers

The Markers panel

In and out marks
An in point and an out point define a range of your sequence — the part you want to play, render,
or export. You set them at the playhead:

I — set the in point at the playhead

O — set the out point at the playhead

The marked range appears as a shaded band across the ruler, with a brighter edge at each end:

To clear a mark, hold Alt:

Alt+I — clear the in point

Alt+O — clear the out point



You don’t have to set them in order. If you set an in point later than the current out point (or an out
point earlier than the in point), Sprocket clears the conflicting mark so the range always makes
sense.

Marks belong to the sequence you’re working in. If you switch to another sequence and come back,
each sequence keeps its own in and out points.

Tip: In and out marks are what the Export dialog’s In/Out range option and the Sequence ▸
Render In to Out command act on. Set them once and every “just this part” action uses the
same range.

Play just the marked range
Once you’ve set an in and an out point, choose Sequence ▸ Play In to Out (Ctrl+Shift+Space) to

preview only that stretch. Playback starts at the in point, stops at the out point, and loops back to
the in point so you can watch the same section over and over while you fine-tune it.

If only one mark is set, playback fills in the missing end — a range with just an in point plays to the
end of the sequence, for example. With no marks at all, it simply plays the whole sequence.

Plain playback with Space ignores the marks entirely, so you always have one key for “play
everything” and one for “play just this bit.”

Markers
A marker is a coloured pin on the ruler that flags a single moment — a good spot for a cut, a lyric
to land a title on, a note to revisit. Unlike in/out marks (of which there’s one pair), you can drop as
many markers as you like.

M — add a marker at the playhead

Shift+M — jump to the next marker

Ctrl+Shift+M — jump to the previous marker

New markers are added at the playhead with a default colour. Adding one and then jumping
between them is the fastest way to lay down a rhythm of edit points and then move between them
without hunting along the timeline.



The Markers panel
To see all your markers in one list, click Markers at the top-right of the Timeline pane. A small
panel opens showing every marker in order:

From here you can:

Add a marker at the playhead with + Add at playhead — the same as pressing M.

Jump to a marker by clicking its label. The playhead moves to that marker’s time.

Remove a marker with the ✕ button on its row.

Each row shows the marker’s time and name — for example 0:04.20 · Marker 2. Markers you
haven’t named show as Marker 1, Marker 2, and so on.

Tip: When the panel is empty it reminds you how to start: press M with the playhead where you
want the first marker.

Related
Editing on the timeline — the editing tools, trimming, and rearranging clips.

Export your finished video — where the in/out range comes into play.

http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/export/exporting#export-your-finished-video


Titles, generators, and adjustment layers
Not everything on your timeline comes from a file. Sprocket can generate clips for you — a title
card, a name-and-role lower third, rolling credits, a solid colour — and drop them straight onto the
timeline. There’s also a special adjustment layer that applies effects to everything beneath it, so
you can grade a whole run of clips in one place.

What’s in this guide
Adding a title or other generator

What each generator does

Editing a title’s text

Styling a title in the Inspector

Adjustment layers

Adding a title or other generator
Put the playhead where you want the new clip to start, then open Clip ▸ Insert and choose what
to add:

Each choice drops a ready-made clip — about five seconds long — onto a video track at the
playhead. Once it’s there, you edit it like any other clip: move it, trim it, change its length, or stack it
on a higher video track so it sits over your footage.

Tip: The same generators also live in the Project panel as items you can drag straight onto a
track, if you’d rather place one by hand than insert it at the playhead.

What each generator does



Generator What you get

Title Centred text over a transparent background — the classic title card.

Lower Third A name and role over a background bar in the lower-left corner.

Credits Roll Multiple lines of credits scrolling from the bottom to the top.

Crawl A single line of text crawling from right to left, ticker-style.

Color Matte A solid block of colour, handy as a background or a quick fade-to-colour.

All of the text generators share the same set of controls in the Inspector — they just start with
different defaults. A Lower Third is a title that begins with two lines of text and a background box;
Credits Roll and Crawl are titles that start out scrolling.

Editing a title’s text
The fastest way to change what a title says is to double-click the title clip on the timeline. A text
box opens right on the clip — type your text, then press Enter (or click away) to commit it. Press

Escape to cancel without changing anything.

This edits the title’s main line of text. For a second line, colours, fonts, and everything else, use the
Inspector.

Styling a title in the Inspector
Select a title clip and the Inspector (right-hand panel) fills with its text controls, grouped into three
sections:



Text — the everyday controls: the main Text and a Secondary line, a Font dropdown, three
alignment buttons (left, centre, right), the Fill colour, Size, letter Tracking, line Leading, and
the Position X / Y of the text on screen.

Text Style — the decorative extras: a Stroke (outline) colour and width, a drop Shadow with
its own colour, offset, and blur, and a Box colour and padding for a background panel behind
the text (this is what gives a lower third its bar).

Scroll & Animate — how the text moves: a scroll mode (None, Roll for credits, or Crawl),
ease-in and ease-out, whether it starts and ends off-screen, and a reveal option.

Every one of these is a normal Inspector control, so you drag the slider, type an exact value, or click
the colour swatch to pick a colour — the same way you adjust an effect on any other clip.

Tip: Because a lower third, credits roll, and crawl are all just titles with different starting settings,
you can turn any one into another. Add a plain Title, then set its Scroll & Animate mode to
Crawl to make it crawl.

Adjustment layers
An adjustment layer is a clip with no picture of its own. Instead, any effects you put on it apply to
every clip on the tracks below it, for as long as the layer lasts. It’s the tidy way to grade or stylise a
whole run of clips at once, instead of copying the same effect onto each one.



Add it from Clip ▸ Insert ▸ Adjustment Layer. Sprocket places it on a track above your footage
so it doesn’t push anything aside:

Now add effects to the adjustment layer the way you would to any clip — for example a Color
effect or a colour-grading effect. The look applies to everything underneath the layer for its span.
To limit which clips are affected, trim the adjustment layer so it only covers them; to change the
look everywhere at once, edit the effect on the single layer.

Tip: Stack more than one adjustment layer for different looks over different parts of your edit —
each one only affects the tracks below it, where it sits.

Related
Editing on the timeline — moving, trimming, and arranging clips (including your titles).

Change how a clip looks — the effects you can add to an adjustment layer.

Color grading — grading tools that pair well with an adjustment layer.

http://localhost:4321/docs/effects-color/effects#change-how-a-clip-looks
http://localhost:4321/docs/effects-color/color-grading
http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/effects-color/effects#change-how-a-clip-looks
http://localhost:4321/docs/effects-color/color-grading


Multicam and sequences
Once you’re comfortable editing a single timeline, Sprocket has three features for bigger projects:
multicam lets you cut between several camera angles of the same moment, sequences let you
keep more than one timeline in a project, and nesting collapses a group of clips into one so a
complex edit stays manageable.

What’s in this guide
Cutting between camera angles (multicam)

Working with more than one sequence

Nesting clips into a sequence

Cutting between camera angles (multicam)
If you filmed the same scene with more than one camera, multicam lets you line the angles up once
and then cut between them by pressing a number key — like switching cameras in a live broadcast.

Set it up: put each camera’s footage on its own video track, lined up in time (one track per angle),
then choose Clip ▸ Create Multicam Source. This combines the angles into a single synced
multicam clip. (The command is available once you have clips on at least two video tracks.)

Cut between angles: with the multicam clip selected, put the playhead where you want to switch
and press a number key — 1 for the first angle, 2 for the second, and so on up to 9. Each press cuts
to that angle at the playhead, so playing through shows your footage cutting from camera to
camera exactly where you switched.

You can also change the angle from the Multicam section of the Inspector, which shows an Active
angle row with one button per angle and the current one highlighted.

The clip’s label on the timeline shows both the source and the current angle, so you can always see
which camera is live at a given point.

Working with more than one sequence



A sequence is a single timeline. Most projects have just one, but you can keep several in the same
project — a rough cut and a final cut, a main video and a separate intro, or one sequence per
scene. The Sequence menu manages them:

New Sequence creates a fresh, empty timeline. It’s named automatically (Sequence,
Sequence 2, …) and starts with one video and one audio track, matching your current
sequence’s frame rate and resolution. Sprocket switches to it right away.

Open Sequence lists every sequence in the project; pick one to switch to it. The sequence
you’re currently in is ticked.

Sequence Settings… opens a dialog where you can rename the current sequence. It also
shows the sequence’s format — resolution, frame rate, and audio sample rate — for
reference:



The name of the sequence you’re editing is shown near the top-right of the window, so you always
know which one you’re in.

Nesting clips into a sequence
Nesting takes a group of clips and tucks them into their own sequence, replacing them on your
timeline with a single clip that stands in for the whole group. It’s the answer to a timeline that’s
grown busy: collapse a finished section — a title sequence, a montage, a multi-layer composite —
into one clip you can move and trim as a unit.

Select the clips you want to group (see Selecting several clips at once), then choose Sequence ▸
Nest. Sprocket moves those clips into a new sequence and drops a single nested-sequence clip in
their place, drawn in teal and labelled with the new sequence’s name:

The nested clip behaves like any other clip on your timeline — move it, trim it, add effects to it. To
edit what’s inside it, open its sequence from Sequence ▸ Open Sequence and edit those clips
directly; the nested clip updates to match.

Tip: Nesting is one undo step. If the group wasn’t quite right, Ctrl+Z puts the clips back exactly
as they were.

Related
Editing on the timeline — selecting, moving, and trimming clips, including the nested clips
you create here.

Marks and markers — set an in/out range in any sequence.

http://localhost:4321/docs/edit/editing-on-the-timeline#selecting-several-clips-at-once
http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/edit/marks-and-markers


Effects & the effect stack
Effects change how a clip looks and sounds — its brightness, color, size, position, and fades.
Sprocket ships with a broad set: everyday adjustments like Transform, Color, Brightness, and
Fade; a suite of dedicated color-grading tools; and a deep library of audio effects. They all work the
same way, they all live in the Inspector, and you can stack as many as you need on a single clip.

What’s in this guide
Change how a clip looks

Where to go next

Change how a clip looks
Effects let you adjust a clip’s picture — its brightness, color, size, and position. To add one:

1. Select the clip you want to change.

2. Open the Effects menu and choose an effect. Transform, Color, Brightness, and Fade cover
the everyday adjustments; the rest of the menu holds color-grading tools for when you need
them.

http://localhost:4321/docs/effects-color/color-grading


The effect appears as a new section in the Inspector, where you control it. For example, Transform
lets you scale, reposition, and rotate the picture, while Color adjusts exposure, contrast, saturation,
and vibrance.

Drag a slider or type a value into the box to change a setting. The preview updates as you go.

To remove an effect, click the ✕ on its section heading.

You can also click + Effect at the bottom of the Inspector to add one without using the
menu.

Tip: See the small diamond next to each setting? That’s for keyframing — animating a value so
it changes over time (for example, a clip that slowly zooms in). It’s there when you’re ready for it.

Where to go next
Color grading — White Balance, Color Wheels, Curves, and the HSL Qualifier for finer control
over color.

Transitions — blend one clip into the next at a cut.

Adjust the audio — mute, solo, and fade a clip’s sound.

http://localhost:4321/docs/effects-color/color-grading
http://localhost:4321/docs/effects-color/transitions
http://localhost:4321/docs/audio/audio-mixing


Transitions
A hard cut drops you straight from one shot to the next. A transition eases the change instead —
the outgoing clip blends into the incoming one over a short window, so the edit feels smooth
rather than abrupt. Sprocket comes with the handful of transitions you’ll reach for most: a cross
dissolve, two dips through black or white, and a wipe.

This guide shows you where to find them and how to drop one onto a cut.

If you haven’t arranged any clips yet, start with the Getting started guide and Editing on the
timeline.

What’s in this guide
Before you start

The transitions you can use

Add a transition to a cut

What a transition looks like on the timeline

Remove a transition

Good to know

Before you start
A transition goes on a cut — the point where one clip ends and the next begins — so you need
two clips sitting next to each other on the same track, with no gap between them.

The quickest way to get there is File ▸ Open Sample Project, then split the video clip into two
pieces with the Blade tool (see Split a clip with the Blade). The two halves now meet at a cut, ready
for a transition.

The transitions you can use
Open the Project panel on the left and click the Transitions tab. Each transition shows its name
and a one-line description of what it does.

http://localhost:4321/docs/get-started/getting-started
http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/get-started/getting-started#5-split-a-clip-with-the-blade


Cross Dissolve — fades the outgoing clip directly into the incoming one. This is the standard
transition and the one you’ll use most.

Dip to Black — fades the outgoing clip down to black, then black up to the incoming clip.
Good for marking a break in time or place.

Dip to White — the same idea, but through white instead of black.

Wipe — the incoming clip slides in over the outgoing one, left to right.

Add a transition to a cut
There are two ways to apply a transition. Both put it on a cut between two adjacent clips.

Drag it onto the cut. Drag a transition from the Transitions tab and drop it onto the cut between
your two clips. As you drag near a cut, Sprocket highlights where the transition will land, then snaps
it to that cut when you release.

Or double-click it. Select one of the two clips beside the cut, then double-click the transition in
the list. Sprocket adds it to that clip’s cut — the one it shares with the next clip if there is one,
otherwise the cut with the previous clip.

Either way, the status bar confirms the result (for example, Added Cross Dissolve), and the new
transition appears on the cut.



Tip: If nothing happens, the clip you selected probably doesn’t have a neighbor to blend with. A
transition always needs two clips meeting at a cut — check that the clips are touching, with no
gap between them.

What a transition looks like on the timeline
A transition shows up as a shaded box with a bow-tie X straddling the cut, centered on the edit
point so it overlaps the end of the first clip and the start of the second.

Play across the cut in the Program monitor to see the transition in action — the picture eases from
one clip into the next over the length of the box.

Remove a transition
1. Switch to the Select tool.

2. Click the transition’s box on the cut. Its outline brightens to show it’s selected.

3. Press Delete.

The transition is removed and your clips go back to a plain cut. As with every edit in Sprocket, you
can bring it back with Undo (Ctrl+Z).

Good to know
Transitions land on a one-second window centered on the cut, trimmed to whole frames.
On very short clips the window is shortened to fit.

A transition needs footage on both sides of the cut. Because it overlaps the two clips, it
blends the end of one shot with the start of the next — so it works best where both clips have
a little room around the edit.

To swap one transition for another, remove the one that’s there and add the one you want
— Sprocket doesn’t replace it automatically.



Related
Editing on the timeline — trim and arrange the clips you’ll be joining with transitions.

Getting started — split a clip with the Blade tool to create a cut.

Change how a clip looks with effects — fades and other looks you apply to a single clip.

http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/get-started/getting-started#5-split-a-clip-with-the-blade
http://localhost:4321/docs/effects-color/effects#change-how-a-clip-looks


Color grading
Color and Brightness (covered in Effects & the effect stack) handle the everyday adjustments —
exposure, contrast, saturation. The rest of the Effects menu is a set of dedicated color-grading
tools for when you want more control: balancing color casts, shaping shadows and highlights
separately, or isolating a single color.

Every tool here works the same way as any other effect: select a clip, choose it from the Effects
menu, and adjust it in the Inspector. You can add as many as you need to one clip — they stack.

Shooting log? Convert flat log footage to a normal picture first — see Working with log &
camera footage.

What’s in this guide
Judging your grade with scopes

White Balance

Color Wheels

Curves

HSL Qualifier

Judging your grade with scopes
Your eyes adapt to a screen quickly, which makes it easy to misjudge color by looking alone. The
Scopes menu, next to the Program monitor’s Guides button, overlays a technical readout of the
current frame underneath the preview:

http://localhost:4321/docs/effects-color/effects#change-how-a-clip-looks
http://localhost:4321/docs/media/log-footage
http://localhost:4321/docs/media/log-footage


Waveform — plots brightness across the frame from left to right, so you can see at a glance
whether your shadows are crushed or your highlights are blown out.

RGB Parade — the same idea as Waveform, but split into separate red, green, and blue
traces, useful for spotting a color cast.

Vectorscope — plots color as a dot cloud around a wheel; the direction shows the hue and
the distance from center shows how saturated it is.

Histogram — a standard brightness histogram across the whole frame.



Tip: Turn on a scope before you start grading a shot, and leave it on. It’s much easier to catch a
problem as you introduce it than to spot it afterward.

White Balance
Temperature and Tint correct a color cast — footage that looks too blue (shot in shade or under
overcast sky) or too orange (shot under tungsten light).



Temperature shifts the image between blue and orange.

Tint shifts it between green and magenta, for casts that Temperature alone doesn’t fix.

Use the Vectorscope while you adjust these — a neutral gray or white object in your shot should
sit at the very center of the wheel once the cast is corrected.

Color Wheels
Color Wheels is a classic three-way color corrector: three trackball-style wheels give you separate
control over the shadows, midtones, and highlights of the image.

Lift — shifts the shadows (the darkest parts of the image).

Gamma — shifts the midtones.

Gain — shifts the highlights (the brightest parts).

Each wheel works the same way:

Drag anywhere on the wheel to tint that tonal range — the white puck jumps to where you
point, and the further it sits from the center, the stronger the tint. Hold Shift while dragging

for fine adjustments.

Double-click a wheel to recentre its puck and remove the tint.

The slider underneath brightens or darkens that range without changing its color — the
slider under Lift raises or lowers the shadows, and so on.

Channels (below each slider) opens individual R, G, and B sliders for that range, if you’d
rather work with exact numbers than drag the wheel.

For example, to pull a blue cast out of the shadows, drag the Lift puck slightly away from blue
(toward yellow); to warm up the highlights, drag the Gain puck a little toward orange. A whole drag
is a single undo step, so Ctrl+Z takes back the entire move, not one pixel of it.



Tip: Small moves go a long way here. A little bit of blue in the shadows and a little warmth in the
highlights is a classic, subtle look — pushing a puck far from the center starts to look unnatural
fast.

Curves
Curves adjusts the tonal response of the image at five points — Blacks, Shadows, Mids,
Highlights, and Whites — running from the darkest to the brightest part of the picture.

The RGB group adjusts all three color channels together, affecting overall contrast and brightness
at each of the five points. Below it, separate Red, Green, and Blue groups let you push an
individual color channel at the same five points — useful for correcting a cast that only shows up in
part of the tonal range (green shadows but otherwise-neutral highlights, for example) rather than
the whole image evenly.

HSL Qualifier
The tools so far all affect the entire frame. HSL Qualifier is different — it isolates a range of color
first, then applies a correction to only that range. This is how you change the color of one thing in a
shot (a sky, a piece of clothing, a logo) without touching everything else.



Work through it top to bottom:

1. Hue Center and Hue Width pick the range of colors to select, and Hue Softness feathers the
edge of that selection. Sat Low/Sat High and Luma Low/Luma High narrow the selection
further by saturation and brightness.

2. Turn on Show Mask while you’re setting up the selection — it replaces the preview with a
black-and-white mask so you can see exactly what’s selected before you apply any correction.

3. Once the selection looks right, turn Show Mask back off and use Hue Shift, Saturation, and
Exposure to correct just that color.

Tip: Widen Hue Softness if the correction looks like it has a hard, visible edge around it — a
softer selection blends more naturally into the rest of the frame.

Related
Effects & the effect stack — the everyday Color, Brightness, Transform, and Fade effects.

Working with log & camera footage — convert flat log footage to a normal picture before
grading it.

A quick tour of the main screen — the Program monitor’s Guides and Fit controls.

http://localhost:4321/docs/effects-color/effects#change-how-a-clip-looks
http://localhost:4321/docs/media/log-footage
http://localhost:4321/docs/get-started/getting-started#a-quick-tour-of-the-main-screen


Audio levels & the mixer
Every audio track carries its own sound, and Sprocket gives you simple per-track controls to
balance them: mute a track you don’t want to hear, solo one you want to focus on, and fade a clip’s
audio in or out.

What’s in this guide
Adjust the audio

Where to go next

Adjust the audio
Each audio track has two small buttons in its header on the left of the timeline:

M — mute the track so you don’t hear it.

S — solo the track so you hear only it and nothing else.

To fade audio in or out, select the audio clip and add the Fade effect from the Effects menu, the
same way you added a picture effect. (Video tracks have their own toggle — the eye icon — to hide
or show a track’s picture.)

Where to go next
Effects & the effect stack — how to add, adjust, and remove any effect, including Fade.

http://localhost:4321/docs/effects-color/effects


Exporting your video
Exporting turns your timeline into a single video file you can upload or share. Sprocket’s defaults
produce a widely compatible file for most uses, and you can change the format, quality, and other
settings whenever you need something specific.

What’s in this guide
Export your finished video

Where to go next

Export your finished video
Exporting turns your timeline into a single video file you can upload or share.

1. Click the Export button in the top-right (or press Ctrl+E).

2. Choose your settings in the Export Settings window.

3. Click Export…, pick where to save the file, and Sprocket renders it.



The defaults produce a widely compatible MP4 file (H.264 video, AAC audio) at your project’s size
and frame rate — a good choice for most uses. When you need something specific, you can
change:

Format and codecs — the file type and how the video and audio are compressed.

Quality — higher quality makes a larger file.

Resolution and Frame rate — the size and smoothness of the export.

Burn-ins — optionally stamp a timecode, the clip name, or your own watermark text onto
the video.



If you often export with the same settings, save them as a preset with Save Preset… and pick them
from the Preset menu next time.

Where to go next
Getting started with Sprocket — build an edit from first playback to this export step.

http://localhost:4321/docs/get-started/getting-started


Troubleshooting choppy playback
If the preview stutters, freezes, or plays less smoothly than your finished export will, the Playback
Statistics window shows you why. It’s a small floating readout of how well playback is keeping up
— the frame rate you’re getting versus the one you should be getting, how many frames were
skipped, and whether your computer is decoding the video on its graphics card (fast) or its
processor (slower).

You don’t need it for everyday editing. Reach for it when playback feels wrong and you want to
know what’s going on.

What’s in this guide
Open the Playback Statistics window

What the numbers mean

What healthy playback looks like

If the preview can’t keep up

Open the Playback Statistics window
Open the View menu and choose Playback Statistics.

A small window appears near the top-right of the editor and stays on top while you work. It doesn’t
take over the keyboard — Space still plays and pauses the preview — so you can leave it open,



start playback, and watch the numbers move.

To close it, click its ✕ or choose View ▸ Playback Statistics again.

Tip: Hover over any row in the window for a plain-language explanation of that number.

What the numbers mean
Start playback and the readout updates about twice a second:

The top section describes playback itself:

Row What it tells you

State Whether the preview is playing or paused.

Position Where the playhead is, and the total length of what’s loaded.

Video
decode

The video format being decoded, and whether it’s decoded on the GPU (your
graphics card — fast) or in software on the CPU (slower).



Row What it tells you

Timeline
rate

Your sequence’s frame rate — the rate the preview is trying to hit.

Preview rate The frames actually shown per second, averaged over the last few seconds.

Dropped
frames

Frames the preview had to skip to keep pace. The count is for the current play —
it resets each time you press play.

Frames
shown

Total frames displayed since playback started.

Pump rate How many times per second the playback engine schedules a frame (it should sit
near the timeline rate).

The bottom section shows what the app is costing your computer: CPU use, memory (Working
set), and a few technical rows (Managed heap, GC, Threads) that are mainly useful when reporting
a performance problem.

Colors carry the verdict throughout: green is healthy, amber is worth a look, and red means
playback is suffering right now.

Tip: The readout follows whichever preview is active — switch between the Program and Source
tabs and it switches with you.

What healthy playback looks like
During smooth playback you’ll see:

Preview rate in green, sitting at (or within a frame of) the Timeline rate.

Dropped frames at 0, in green.

Video decode in green, naming your graphics card with (GPU).

When playback is paused, a preview rate near zero is normal — the preview only draws when
something changes.

If the preview can’t keep up



A red Preview rate and a climbing Dropped frames count mean the preview is falling behind. The
first thing to check is the Video decode row:

Amber, ending in “software (CPU)” — the video is being decoded on the processor instead
of the graphics card. This is the most common cause of stuttery 1080p playback, and it
usually comes down to your graphics card or its driver not accelerating that video format.
Updating the graphics driver is the first thing to try.

Green (GPU) but still dropping frames — the machine is busy elsewhere. Check the CPU
row; if it’s amber or red, closing other heavy programs gives the preview more headroom.

Dropped frames only ever count against the preview — your exported video is rendered separately
and always comes out at full quality, even if playback stuttered while you edited.

Tip: The status bar at the bottom of the window shows a live frame rate too, and its state dot
turns amber during playback whenever the software (CPU) decode path is in use — a quick hint
that it’s worth opening Playback Statistics.

Related
Play and preview your video — the playback controls themselves.

A quick tour of the main screen — where the status bar’s live playback stats live.

http://localhost:4321/docs/get-started/getting-started#1-play-and-preview-your-video
http://localhost:4321/docs/get-started/getting-started#a-quick-tour-of-the-main-screen


AI control (MCP)
Sprocket can hand an AI assistant the controls: with AI control switched on, an AI client running on
your computer — Claude Code, Claude Desktop, or any other app that speaks the open MCP
(Model Context Protocol) standard — can look at your open project and edit it for you. You type
“tighten the gaps in the first minute and add a title,” and the AI makes the edits on your timeline,
using the same operations you would.

It’s off by default, only ever reachable from your own computer, and every edit an AI makes lands
in the same undo history as your own — one Ctrl+Z puts things back.

What’s in this guide
Turn on AI control

The status bar tells you when it’s on

Connect an AI client

Require a bearer token

Edit by prompt

AI edits are undoable

Effect reference tags

What AI can do: the tool reference

Starting from the command line

Turn on AI control
1. Open Edit ▸ Preferences (Ctrl+,) and scroll to the AI control (MCP) section.

2. Check Enable MCP server (loopback only).

3. Leave the Port at its default (41008) unless another program on your computer already uses
it. Any port from 1024 to 65535 works.

4. Click OK.



That’s the whole switch. While it’s on, Sprocket runs a small MCP server that AI clients on this
computer can connect to. As the note under the checkbox says: while enabled, a local AI client can
inspect and edit the open project — so leave it off when you’re not using it.

Loopback only means exactly that: the server accepts connections only from your own computer
(127.0.0.1). Nothing on your network — let alone the internet — can reach it, and requests from
web pages in your browser are rejected too. If you want to shut out other programs on your own
machine as well, add a bearer token.

The status bar tells you when it’s on
Whenever the server is running, an indicator appears in the status bar at the bottom of the main
window — a green dot and the port, next to the engine state:

Green dot + “MCP :41008” — the server is listening on that port. Hover it for a reminder of
what that means.

Red dot + “MCP error” — you switched it on but the server couldn’t start (usually the port is
taken by another program). Hover the indicator to see the exact error, then pick a different
port in Preferences.

No indicator — AI control is off.

You’ll never see Sprocket externally controllable without this indicator showing — it exists precisely
so you always know.



Connect an AI client
Sprocket writes the connection command for you:

1. In Edit ▸ Preferences ▸ AI control (MCP), click Copy setup command.

2. Paste it into a terminal. For Claude Code the copied command looks like:

3. Start a conversation and ask the AI something about your project — for example, “what clips
are on my timeline?” If it answers with your actual clips, you’re connected.

Using a different AI client? Point it at the same address — http://127.0.0.1:41008/mcp (with your

port) — as an HTTP MCP server. If you’ve turned on the bearer token, the client must also send it as
an Authorization: Bearer <token> header; the copied setup command includes this
automatically.

Tip: Connecting is a one-time setup per client. After that, just have Sprocket running with AI
control on, and the client finds it.

Require a bearer token
Loopback-only already keeps everything off your network. The optional token goes one step
further and shuts out other programs on your own computer: with it on, a client that doesn’t present
the token gets refused.

1. In Edit ▸ Preferences ▸ AI control (MCP), check Require bearer token.

2. A token appears in the field below — Sprocket generates it the first time you switch the
requirement on, and keeps it thereafter.

3. Click Copy setup command — the copied command now includes the token — and re-run it
in your AI client so the client sends it.

Unchecking Require bearer token keeps the token stored, so switching it back on later doesn’t
break clients you’ve already set up.

Edit by prompt

claude mcp add --transport http sprocket http://127.0.0.1:41008/mcp



Once connected, you direct the AI in plain language. It can see the project — media pool, tracks,
clips, effects, markers, playhead — so you can refer to things the way you’d describe them to a
person:

“Cut the first three seconds off the opening clip and close the gap.”

“Add a cross dissolve at every cut on the video track.”

“Put a title that says ‘Day Two’ at the 30-second mark.”

“Warm up the interview clip a little and bring the saturation down.”

“Drop a marker at every point where the music changes.”

“Export the whole sequence to D:\renders\rough-cut.mp4.”

The AI edits through the same operations the app itself uses — trims respect linked audio/video,
effects get the same value clamping, placements snap to the same rules — so nothing an AI does
can produce an edit you couldn’t have made yourself. The preview updates as it works.

AI edits are undoable
Every edit an AI makes goes through the same undo history as your own edits — one shared list,
in order. Press Ctrl+Z (or Edit ▸ Undo) and the last change is undone whether you made it or the
AI did. The Edit menu shows the name of each step, so you can see exactly what it’s about to undo.

An AI performing a multi-step job (say, building a title sequence) can group its steps so they undo
as a single entry — you’ll see one named step in the Edit menu instead of a dozen. And since the AI
can also use undo and redo, you can simply tell it “undo that” as well.

Effect reference tags
Look at any effect header in the Inspector and you’ll see a small chip next to its name — CO-1, TR-
4, and so on:



That’s the effect’s reference tag: a short code for the effect type plus a number that counts up
across the project. It’s a stable handle — the tag sticks to that specific effect instance even if you
reorder the stack, and a number is never reused within a project.

Tags exist mainly for AI control: they’re how an AI client addresses one specific effect without
ambiguity. You can use them in prompts, too — “set TR-4’s scale to 1.5” or “remove CO-1 from the
interview clip” — which is handy when a clip carries two effects of the same type.

What AI can do: the tool reference
A connected client gets a set of about 70 tools — the complete surface, by area:

Area Tools

Inspect the
project

get_project_state, list_media, list_clips, get_clip, get_playhead,

list_effect_types, list_transition_types, list_generator_types,
list_audio_chain



Area Tools

Playback & the
playhead

seek, play, pause, stop, go_to_start, go_to_end, step_frames

Import & place
media

import_media, add_clip_to_timeline

Edit clips trim_clip, move_clip, split_clip, delete_clip, duplicate_clip,
set_clip_fade, set_clip_speed, set_clip_gain, unlink_clip, link_clips

Ripple / roll / slide ripple_trim, roll_edit, slide_clip, ripple_delete

Effects on clips add_effect, set_effect_parameter, set_effect_parameter_keyframes,
remove_effect, move_effect, copy_effects, set_effect_enabled

Audio chains
(track / bus /
master)

add_chain_effect, remove_chain_effect, set_chain_effect_parameter

Transitions add_transition, remove_transition, set_transition

Markers add_marker, remove_marker, update_marker

Tracks add_track, remove_track

Titles &
generators

add_generator_clip, set_generator_text, set_generator_parameter

Undo & grouping undo, redo, begin_edit_group, end_edit_group, cancel_edit_group

Project files open_project, close_project, new_project, save_project,

save_project_as

Export export_video, export_audio, get_export_status, cancel_export

A few boundaries worth knowing:

No dialogs. An AI can’t drive Sprocket’s windows — it can’t answer a file picker for you, so
saving a brand-new untitled project needs one manual File ▸ Save As from you first.

Unsaved changes are protected. Opening or creating another project fails while the current
one has unsaved changes, unless the AI explicitly discards them — it can’t silently drop your



work.

One export at a time, same as in the app.

Starting from the command line
Two launch flags start the server for this session only, without touching your saved preference:

This is handy for scripted or occasional use: launch with the flag when you want AI control, and
every normal launch stays off. A session started this way still honours your saved token setting, and
the status-bar indicator shows as usual.

Tip: For scripted launches that need a token, put it in the SPROCKET_MCP_TOKEN environment

variable rather than on the command line — other local processes can read a command line, but
not your environment.

Related
Getting started with Sprocket — the editing concepts an AI works with: clips, tracks, effects,
markers.

Editing on the timeline — what ripple, roll, slip, and slide mean when you ask an AI for them.

Color grading — the grading effects an AI can apply and keyframe.

Sprocket --mcp              # start with AI control on, using your saved port

Sprocket --mcp-port 45000   # same, on a specific port

http://localhost:4321/docs/get-started/getting-started
http://localhost:4321/docs/edit/editing-on-the-timeline
http://localhost:4321/docs/effects-color/color-grading
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